Project

General

Profile

Actions

Bug #1134

closed

Sometimes the tab after a new tab in the middle of a list is set as active

Added by ask low 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Next Release
Start date:
12/10/2023
Due date:
% Done:

0%

Estimated time:

Description

This behaviour is very odd. I can't reproduce this behavior. It seems very random. Can you look into this ?
https://t.ly/LzrVW
It happens when I use the browser quickly. But it's happening very rarely. Can you try to reproduce this issue on your device ? Make sure follow the same steps & speed of usage. I've re-recorded the above screenshare like 15 times to capture the bug actually.


Files

invalid_package.png (44 KB) invalid_package.png ask low, 12/14/2023 04:07 AM
pb.log (58.7 KB) pb.log ask low, 12/16/2023 04:59 AM
Actions #1

Updated by ask low 6 months ago

  • Subject changed from New tab searches don't get utilised to New tab searches don't get utilised sometimes
Actions #2

Updated by ask low 6 months ago

Instead of using the opened new tab, pb replaces the farthest right tab with the one searched from the url bar.

Actions #3

Updated by Soren Stoutner 6 months ago

I'll have to take a look and see if I can figure out what is going on.

Actions #4

Updated by Soren Stoutner 6 months ago

  • Subject changed from New tab searches don't get utilised sometimes to Sometimes the tab after a new tab in the middle of a list is set as active
  • Status changed from New to Feedback
Actions #5

Updated by Soren Stoutner 6 months ago

@ask low, can you please test this alt build of Privacy Browser to see if it resolves the problem for you? You can install it alongside your existing Privacy Browser. The link below will expire in about a week.

https://nextcloud.stoutner.com/s/S2eqBQBZL2q5Eaq

Actions #7

Updated by Soren Stoutner 6 months ago

Sorry about that. Try this version:

https://nextcloud.stoutner.com/s/BHLZ4b9Ziw4JNKW

Actions #8

Updated by ask low 6 months ago

You can close this in favor of #1136.

Actions #9

Updated by Soren Stoutner 6 months ago

I'm not 100% sure yet that these two bugs have the same root cause. However, if the proposed fix handles both of them, then I will close this one as a duplicate of that.

Actions #10

Updated by ask low 6 months ago

Happened on the test version.

Actions #11

Updated by Soren Stoutner 6 months ago

I will have to think through some other possible solution.

Actions #12

Updated by Soren Stoutner 6 months ago

Here is a new build you can test. Unlike the previous test version, this change has the potential to possibly break other things, particularly possibly not restoring tabs in the same order, but I have been running it for a few days without encountering any problems.

https://nextcloud.stoutner.com/s/BxtSX3NczFQiLyc

Like usual, this link will expire after a few weeks. Please let me know if 1) this fixes your problem, and 2) you notice any regressions.

Actions #13

Updated by Soren Stoutner 6 months ago

https://gitweb.stoutner.com/?p=PrivacyBrowserAndroid.git;a=commitdiff;h=83a2b6e5635956bb940642e0e5beb47453145dc3;ds=sidebyside attempts to make some progress on this issue, although it might not fully resolve it.

Actions #14

Updated by ask low 6 months ago

Sure. You can provide alt builds to test.
Although, I currently don't daily drive PB (as long as 1MB SISB crash exists). Moved all of my cookies into FOSS browser, but still hop on PB for anonymous surfing.

Actions #15

Updated by Soren Stoutner 6 months ago

This is the build I already provided to test.

Actions #16

Updated by ask low 6 months ago

The commit was of yesterday right ? You probably provide some nextcloud shared link. Sorry but I couldn't find it.

Actions #17

Updated by Soren Stoutner 6 months ago

The commit is the same as the build in #note-13.

Actions #18

Updated by ask low 6 months ago

I meant, you provided commit diff in #note-13, but not the build. Sorry but I think either I didn't understood how to get apk or you didn't provide it.

Should I have to compile apk like on my system ?

Actions #19

Updated by Soren Stoutner 6 months ago

Sorry, I should have said that the commit in #note-13 is the same as the build in #note-12.

Actions #20

Updated by ask low 6 months ago

Ah ok. Btw that's 7 days ago. Maybe it's a different race condition then.

You know what? I think it's better you should revert back the new tab adjacent spawn patch altogether & then add newer commits one by one by making sure the race conditions are treated well?

Actions #21

Updated by Soren Stoutner 6 months ago

I added the link to the test version and waited a while to see if there were any responses. As nothing was said, I added the commit about a week later.

It still isn't clear if this fixes the problem as you haven't commented either way. But I think this commit improves the code anyway, and my testing indicates it doesn't break anything, so I committed it.

Actions #22

Updated by ask low 6 months ago

I've reinstalled #note-12 just now & been manhandling the new tabs. Will let you know in couple days.

Actions #23

Updated by Soren Stoutner 5 months ago

@ask low, have you encountered any problems with this test build?

Actions #24

Updated by ask low 5 months ago

Forgot to share my results here lmao. No new tab spawn issues until now.
But I'm not sure what #1136 issue is. Can you explain exactly what that is ? Caz the description defines similar meaning of this issue.

Actions #25

Updated by Soren Stoutner 5 months ago

  • Status changed from Feedback to Closed

Thanks for the update. Closing with the previously mentioned commit in #note-13.

Actions

Also available in: Atom PDF