Project

General

Profile

Actions

Bug #1197

closed

Only files of the first type are selectable in the file picker when multiple types are requested

Added by jindam vani about 1 month ago. Updated 21 days ago.

Status:
Closed
Priority:
Next Release
Start date:
05/20/2024
Due date:
% Done:

0%

Estimated time:

Description

  • version_ Version 3.17 (version code 73)
  • i am trying to upload .mobi files
    on singlelogin.re
  • however, when i try to choose file,
    its greyed out aka either android os
    or browser issue
  • please find screenshot and
    .mobi file

Files

lightning.webp (35.7 KB) lightning.webp jindam vani, 05/21/2024 05:40 PM
privacy3.webp (71.1 KB) privacy3.webp jindam vani, 05/21/2024 05:40 PM
privacy2.webp (70.9 KB) privacy2.webp jindam vani, 05/21/2024 05:40 PM
privacy1.webp (58.7 KB) privacy1.webp jindam vani, 05/21/2024 05:40 PM
Actions #1

Updated by Soren Stoutner about 1 month ago

  • File Test.mobi added
  • Status changed from New to Feedback
  • Assignee set to Soren Stoutner

I was able to upload the Test.mobi file here using Privacy Browser Android 3.17. Is this problem limited to singlelogin.re, or are you also not able to uoload .mobi files using Privacy Browser on redmine.stoutner.com?

Actions #2

Updated by jindam vani about 1 month ago

Soren Stoutner wrote in #note-1:

I was able to upload the Test.mobi file here using Privacy Browser Android 3.17. Is this problem limited to singlelogin.re, or are you also not able to uoload .mobi files using Privacy Browser on redmine.stoutner.com?

  • specific to singlelogin.re
  • attached .mobi on redmine
  • off-topic_ now eveeybody knows, what
    am i doing ;)
Actions #3

Updated by Soren Stoutner about 1 month ago

  • File deleted (book (1).mobi)
Actions #4

Updated by Soren Stoutner about 1 month ago

  • File deleted (Test.mobi)
Actions #5

Updated by Soren Stoutner about 1 month ago

  • File deleted (Screenshot_2024-05-19_23-06-15.webp)
Actions #6

Updated by Soren Stoutner about 1 month ago

jindam vani wrote in #note-2:

  • specific to singlelogin.re

Can you upload .mobi files on singlelogin.re using other browsers?

  • off-topic_ now eveeybody knows, what
    am i doing ;)

I'm not sure exactly what you are referring to here, but I deleted the attachments in case they contained sensitive information.

Actions #7

Updated by jindam vani about 1 month ago

Soren Stoutner wrote in #note-6:

jindam vani wrote in #note-2:

  • specific to singlelogin.re

Can you upload .mobi files on singlelogin.re using other browsers?

yes, firefox android 126.0 (Build #2016019896)

  • off-topic_ now eveeybody knows, what
    am i doing ;)

I'm not sure exactly what you are referring to here, but I deleted the attachments in case they contained sensitive information.

  • it was open access ebook
    with cc license
Actions #8

Updated by Soren Stoutner about 1 month ago

Websites can restrict which files the file picker allow you to upload.

https://developer.mozilla.org/en-US/docs/Web/HTML/Element/input/file

My guess is that either 1) Privacy Browser is getting a different file list restriction based on some aspect of its settings or 2) WebView is having a hard time understanding the instructions.

Let's see if we can narrow it down by looking at the following three things.

1. What domain settings are you using for singlelogin.re? Most interestingly, which user agent are you using?

2. Do you experience the same problems with another browser based on WebView, like Lightning?

https://f-droid.org/en/packages/acr.browser.lightning/

3. Please post a copy of About > Version from Privacy Browser.

Updated by jindam vani about 1 month ago

Soren Stoutner wrote in #note-8:

Websites can restrict which files the file picker allow you to upload.

https://developer.mozilla.org/en-US/docs/Web/HTML/Element/input/file

My guess is that either 1) Privacy Browser is getting a different file list restriction based on some aspect of its settings or 2) WebView is having a hard time understanding the instructions.

Let's see if we can narrow it down by looking at the following three things.

1. What domain settings are you using for singlelogin.re? Most interestingly, which user agent are you using?

  • user agent_ privacy
  • please find .webp attachments

2. Do you experience the same problems with another browser based on WebView, like Lightning?

https://f-droid.org/en/packages/acr.browser.lightning/

no, please find lighting.webp attachment

3. Please post a copy of About > Version from Privacy Browser.

Privacy Browser
Version 3.17 (version code 73)

Hardware
Brand: samsung
Manufacturer: samsung
Model: SM-J701F
Device: j7velte
Bootloader: J701FDDUACUG2
Radio: J701FXXUACUF1,J701FXXUACUF1

Software
Android: 9 (API 28)
Security Patch: 2021-04-01
Build: PPR1.180610.011.J701FDDUACUG2
Kernel: 3.18.91-16078765
WebView Provider: com.google.android.webview
WebView Version: 124.0.6367.123

Memory Usage
App Consumed Memory: 27.81 MiB
App Available Memory: 2.69 MiB
App Total Memory: 30.50 MiB
App Maximum Memory: 192.00 MiB
System Consumed Memory: 1,352.11 MiB
System Available Memory: 448.56 MiB
System Total Memory: 1,800.68 MiB

Filter Lists
EasyList: 202402070111
EasyPrivacy: 202402070111
Fanboy’s Annoyance List: 202402070115
Fanboy’s Social Blocking List: 202402070111
UltraList: 1
UltraPrivacy: 3

Package Signature
Issuer DN: CN=FDroid, OU=FDroid, O=fdroid.org, L=ORG, ST=ORG, C=UK
Subject DN: CN=FDroid, OU=FDroid, O=fdroid.org, L=ORG, ST=ORG, C=UK
Start Date: 17-Apr-2016 1:44:13 PM IST
End Date: 03-Sep-2043 1:44:13 PM IST
Certificate Version: 3
Serial Number: 166629308
Signature Algorithm: SHA256withRSA

Actions #10

Updated by Soren Stoutner about 1 month ago

Based on the fact it works with Lightning and not with Privacy Browser, I wonder if changing the User Agent would make a difference. Try WebView Default or Firefox on Android and see if that resolves the issue.

Actions #11

Updated by jindam vani about 1 month ago

Soren Stoutner wrote in #note-10:

Based on the fact it works with Lightning and not with Privacy Browser, I wonder if changing the User Agent would make a difference. Try WebView Default or Firefox on Android and see if that resolves the issue.

  • none, i tried all user agents
Actions #12

Updated by Soren Stoutner about 1 month ago

  • Subject changed from .mobi files in file selection are greyed out to .mobi file selection disabled on singlelogin.re
Actions #13

Updated by Soren Stoutner about 1 month ago

Let me look into this more deeply and see if I can figure out what is going on.

Actions #14

Updated by Soren Stoutner about 1 month ago

  • Subject changed from .mobi file selection disabled on singlelogin.re to Only files of the first type are selectable in the file picker when multiple types are requested
  • Status changed from Feedback to Closed
  • Priority changed from 3.x to Next Release

It turns out that the problem is that Android's intent system only allows one mime type to be specified in an Intent (which opens the file picker). So, when a website requested more than one file extension, only the first was passed to the file picker (converted to a mime type).

The solution is to ignore the file types requested by the website and allow the file picker to select any file (not the best solution in my opinion, but it seems to be the only answer Android allows and is what other browsers are doing).

Fixed in commit: https://gitweb.stoutner.com/?p=PrivacyBrowserAndroid.git;a=commitdiff;h=f40bd0b76668119cdf4043f1fafecafb1a0869b9;ds=sidebyside

I will release 3.18 with this fix in a few days.

Actions #15

Updated by jindam vani about 1 month ago

Soren Stoutner wrote in #note-14:

It turns out that the problem is that Android's intent system only allows one mime type to be specified in an Intent (which opens the file picker). So, when a website requested more than one file extension, only the first was passed to the file picker (converted to a mime type).

The solution is to ignore the file types requested by the website and allow the file picker to select any file (not the best solution in my opinion, but it seems to be the only answer Android allows and is what other browsers are doing).

aha.... fenix devs are reluctant to
add option for opening file but never
disclosed reason _;)

Fixed in commit: https://gitweb.stoutner.com/?p=PrivacyBrowserAndroid.git;a=commitdiff;h=f40bd0b76668119cdf4043f1fafecafb1a0869b9;ds=sidebyside

I will release 3.18 with this fix in a few days.

thank you ;)

Actions #16

Updated by jindam vani 21 days ago

  • just now tested on 3.18
  • browser is recognizing
    .mobi files ;)
  • thank you
Actions #17

Updated by Soren Stoutner 21 days ago

You're welcome.

Actions

Also available in: Atom PDF