Project

General

Profile

Bug #253

Exiting Privacy Browser always destroys cookies

Added by Soren Stoutner 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Critical Bug
Start date:
02/27/2018
Due date:
% Done:

0%

Estimated time:

Description

It looks like some recent changes in WebView (64.0.3282.137) have changed how cookies and other things are stored, and cookies are almost always being wiped out when Privacy Browser is closed, even when closed by swiping. Or perhaps it is also a problem of them not being committed to storage.

History

#1 Updated by Soren Stoutner 10 months ago

  • Status changed from New to Closed

#2 Updated by Soren Stoutner 10 months ago

The root of the problem is that current versions of WebView have become extremely lazy about flushing the cookies to permanent storage. As such, when Privacy Browser closes they are cleared from RAM and lost forever.

The solution is to force `CookieManager` to flush any cookies to permanent storage every time a web page finishes loading.

Fixed in commit https://git.stoutner.com/?p=PrivacyBrowser.git;a=commitdiff;h=d4bad2c66a591a021df10f66d5b74145ee99b78d.

Also available in: Atom PDF