Project

General

Profile

Feature #271

Add warning to the Incognito Mode description that forward/back will not work.

Added by Kristian Rink about 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Next Release
Start date:
04/14/2018
Due date:
% Done:

0%

Estimated time:

Description

Strange yet reproducible behaviour on current F-Droid build: In most situations, I can use the Android device "back" button to navigate to the previous page in my browser history. However, after "something" (spent a longer time on the same page?), this doesn't work anymore. By then, using the Android "back" button will send PrivacyBrowser to the background. If I get back to the app, I'll still be seeing the page I've been on before but browser history's not available anymore. This happens all the time but unfortunately I didn't so far manage to figure out what might be causing it.

History

#1

Updated by Soren Stoutner about 1 year ago

Can you please send me a screenshot of About → Version? It might give me some clues as to why this is happening.

#2

Updated by Soren Stoutner about 1 year ago

  • Status changed from New to Feedback
#3

Updated by Kristian Rink about 1 year ago

After taking a closer look and playing a bit with the configuration, seems this is invalid and actually a layer-8 bug: I apparently did have "Incognito mode" enabled in my configuration and "history" / "back" button worked right just for exactly the amount of time it took to fully load more complex pages. Sorry for bothering - I should have been more careful. :(

#4

Updated by Soren Stoutner about 1 year ago

  • Subject changed from "Back" button not working for browser navigation "after some time"? to Add warning to the Incognito Mode description that forward/back will not work.
  • Priority changed from 2 to Next Release

Thanks for the followup. I think I am going to add a more explicit warning to the description for Incognito Mode that forward/back will not work when it is enabled because this issue seems to come up from time to time.

Also available in: Atom PDF