Project

General

Profile

Bug #373

Sometimes the pinned mismatch dialog shows when there is no mismatch

Added by Soren Stoutner 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Next Release
Start date:
02/02/2019
Due date:
% Done:

0%

Estimated time:

Description

This is likely caused by a race condition between the getting of the new IP addresses and the displaying of the pinned mismatch dialog. If the new IP addresses have not been updated before the check for pinned mismatch is made, the dialog will be shown. However, the new IP addresses often come in while the dialog is being prepared, so that it shows there is not mismatch when it is displayed.

The solution is to spin off the check and display of the dialog to its own method, and not call it until the new IP addresses have been received.

Also available in: Atom PDF