Project

General

Profile

Bug #408

Browser restarts every time when Bluetooth keyboard is connecting/disconnecting

Added by Mister Stringer about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Next Release
Start date:
04/15/2019
Due date:
% Done:

0%

Estimated time:

Description

Since a few weeks I'm using a Bluetooth keyboard (IVSO BT keyboard) with my Samsung Galaxy Tab S4 (original Stock ROM).

When I switch the keyboard on or off, and also when the keyboard is going to power save mode or is waking up from power save mode, the browser restarts. It is not only reloading the page. I can see that the the browser is not only reloading the page, because when before the browser was in fullscreen mode (status bar hidden) it is not longer in fullscreen mode after the "restart" happened, and also the browser history is empty after such an event (back and forward keys are greyed out).

This is very annoying when I'm for example reading a long artikel. After some time the keyboard is going to sleep mode the page reloads and I have to manualy scroll down the page to its last position. Also I can't go back to the previuos page because the back buttons in the browser menu are greyed out.

Because of this bug I changed the standard browser to Firefox Focus on my tablet.

History

#1

Updated by Soren Stoutner about 1 month ago

  • Assignee set to Soren Stoutner

That is an interesting bug. I cannot think of any reason why it would happen, and I do not currently own a Bluetooth keyboard to test with. I will have to acquire a Bluetooth keyboard and see if I can duplicate the problem.

#2

Updated by Mister Stringer about 1 month ago

THX for your really quick resonse.

I borrowed a Logitech BT keyboard from my wife and did some additional tests.

I tested both BT keyboards (IVSO and Logitech) on the following android devices:

Galaxy Tab S4 with Oreo Stock ROM, latest WebView and latest PrivacyBrowser
Note 9 with Pie Stock ROM, latest WebView and latest PrivacyBrowser
Note 4 with an older Oreo RROS CustomROM, WebView version 70.0.3583.110 and PrivacyBrowser version 2.14

The error occured on all devices with both keyboards.

Some addtional information (maybe useless): When I use Nova Launcher, my Live Wallpaper reloads every time when the BT keyboard connects/disconnects. So first I thought the problem is caused by the launcher and switched to some other launchers where the live wallpaper wasn't reloading on every BT (dis)connect. But then I realized that the Problem with PrivacyBrowser still happens on these other launchers and that Firefox Focus don't have this problem at all.

#3

Updated by Soren Stoutner about 1 month ago

  • Priority changed from 3.x to Next Release

Thanks for the additional information.

I have ordered a Bluetooth keyboard and will be able to further diagnose the problem when it arrives. The only thing I can imagine is that it has something to do with how I interface with the Input Method Manager.

#4

Updated by Soren Stoutner about 1 month ago

  • Status changed from New to Closed

So, it turns out that Android, by default, restarts all apps whenever a keyboard is connected/disconnected. Apps can override this behavior by using the `android:configChanges="keyboard|keyboardHidden"` options in the manifest file as documented at https://developer.android.com/guide/topics/manifest/activity-element#config.

Fixed in commit https://git.stoutner.com/?p=PrivacyBrowser.git;a=commitdiff;h=1aa252f44922127b9053655a43b0df4e479438ed.

#5

Updated by Mister Stringer about 1 month ago

THX a lot for your help. :-)

Also available in: Atom PDF