Project

General

Profile

Bug #458

Opening the keyboard in fullscreen mode reveals the statusbar

Added by Moderator ✓ 5 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Next Release
Start date:
06/01/2019
Due date:
% Done:

0%

Estimated time:

Description

It is kept until one re-enters the fullscreen mode.

History

#1

Updated by Soren Stoutner 5 months ago

  • Status changed from New to Closed

This is a bug in Android that has been fixed in newer versions (verified fixed in Android 9).

https://issuetracker.google.com/issues/37130873

#2

Updated by Soren Stoutner 5 months ago

Note that this is related to https://redmine.stoutner.com/issues/389, which is not fixed.

#3

Updated by Moderator ✓ 5 months ago

It is android-related? That's strange, because there are apps that work as intended in fullscreen mode. Would it at leasf be possible to automatically exit and re-enter fullscreen mode in Android <9?

#4

Updated by Soren Stoutner 4 months ago

  • Status changed from Closed to New
  • Priority changed from 3.x to Next Release

Yes, this is a bug in Android. Can you give me an example of an app where this works correctly?

It would be possible to re-hide the status and navigation bars when the keyboard is hidden as long as the app is notified when that happens. A while back I looked at it and, surprisingly, there wasn't any easy way for an app to be notified when a keyboard is shown or hidden. But I will take a look at it again and see if I can find a way.

#5

Updated by Moderator ✓ 4 months ago

So there's [Slide](https://f-droid.org/app/me.ccrama.redditslide), but under closer inspection I figured out that it does not register a closed keyboard, but rather any action that is not typing.

Also wouldn't it be kinda simple to have a notifier for when the app has more vertical space? Or have some kind of transparent auto-positioned overlay and look for it's vheight?

#6

Updated by Moderator ✓ 4 months ago

Also something probably awful yet functioning would be to set the WebView in a floating window and take up all space. I think.

#7

Updated by Soren Stoutner 4 months ago

You are welcome to submit a patch and I will consider it. Before doing so you should take a look at the Code Submission Agreement at https://www.stoutner.com/privacy-browser/contributors/.

#8

Updated by Moderator ✓ 4 months ago

I sure would, if I actually knew how to code anything beyond println.

#9

Updated by Soren Stoutner 4 months ago

I'm thinking a good workaround for this and https://redmine.stoutner.com/issues/389 might be to re-enforce full screen mode every time the WebView scrolls. That has the nice attribute of being very easy to implement. However, it will take some testing to see if it works well if the WebView is scrolled when the keyboard is open or if it introduces other types of bugs in other functionality.

#10

Updated by Moderator ✓ 4 months ago

Well Slide circumveils this by simply hiding the keyboard whenever you interact with it by not typing.

#11

Updated by Soren Stoutner 3 months ago

  • Status changed from New to Closed

Fixed in commit https://git.stoutner.com/?p=PrivacyBrowser.git;a=commitdiff;h=06b9b756054fb1de20c5fcbe4eca22bc2a4ff3ee.

Interestingly, this approach has the effect of immediately reinforcing full screen browsing mode even if the WebView is not scrolled because the WebView's `onScrollChangeListener` is called automatically when the keyboard is closed.

Also available in: Atom PDF