Project

General

Profile

Actions

Bug #555

closed

opened tabs get lost

Added by Peter Lustig almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
3.x
Start date:
04/17/2020
Due date:
% Done:

0%

Estimated time:

Description

Usually I open some tabs (5-30) from social Media apps and switch to the browser later to read the sites

sometimes there is a strange behavior when switching to the browser

it opens normally but then it shows the websites titles and icons one after an other and only the last one gets opened

here's a better description

1. scrolling through my feed in a social media app opening example1.com with privacy browser
2. switch back to social media app as soon as I see the progress bar rising
3. open example2.net
4. see step 2
5. open example3.org
6. repeat step 2 and opening a new page 5-30 times
7. switch to privacy browser

there are no multiple tabs now
instead only one tab is shown
it's title and icon changes very fast from example1.com to example2.net to example3.org ...the last website starts to load

It could also happen that privacy browser crashes and all tabs lost after starting the app again or just the latest one is being saved

Here are some specs:
Android 9 Stock ROM
Fairphone 3
app version from unknown version months ago until current version 3.4.1
battery optimation is disabled for privacy browser

I hope my description is good enough to be understood. It not please email me.

Actions #1

Updated by Soren Stoutner almost 4 years ago

  • Status changed from New to Closed
  • Assignee set to Soren Stoutner

Thanks for the well written bug report. This is actually a duplicate of https://redmine.stoutner.com/issues/461, which has some information about why this happens and the plans to fix it.

Actions

Also available in: Atom PDF