Project

General

Profile

Feature #571

Remove Searx from the list of search engines.

Added by Jesse M 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Next Release
Start date:
05/22/2020
Due date:
% Done:

0%

Estimated time:

Description

They just list public instances of searx now and so probably should be removed as a search engine choice. If I may suggest, https://searx.neocities.org would be a good choice since it's a meta engine that redirects to a random searx instance.

History

#1

Updated by Soren Stoutner 5 months ago

  • Status changed from New to Closed

Duplicate of https://redmine.stoutner.com/issues/549.

The fix has already been committed to git and will be included in the next release.

#2

Updated by Jesse M 5 months ago

My apologies for not looking far enough back in the tracker

#3

Updated by Soren Stoutner 5 months ago

  • Status changed from Closed to In Progress
  • Priority changed from 4.x to Next Release

Sometimes it can be hard to find things, especially if they are already closed.

I just checked, and searx.dev is now down because he had too much traffic. This is a common problem with Searx instances. I think I will reopen this and change it to the neocities URL you recommended.

#4

Updated by Jesse M 5 months ago

Mojeek would be another good choice, since it's one of the few I've seen that uses almost no JS by default (just jQuery which is open source) and I can't seem to get Qwant Lite to return any results (this is mentioned at [[https://redmine.stoutner.com/issues/569]]) and DuckDuckGo appears to have a tracking pixel on its non-JS page (it's blocked by EasyPrivacy). I dunno what DDG is thinking considering how much they prattle on incessantly about privacy....

#5

Updated by Soren Stoutner 5 months ago

  • Subject changed from searx.me is no longer a search engine to Change the Searx instance to searx.neocities.org
#6

Updated by Soren Stoutner 5 months ago

I added a separate feature request for Mojeek. https://redmine.stoutner.com/issues/576

Thanks for pointing them out to me.

#7

Updated by Soren Stoutner 5 months ago

It turns out that searx.neocities.org doesn't work with JavaScript disabled. And it seems like any instance I pick only works well for a few days before it gets overloaded.

I think what I will do is remove Searx from the default search engine list. Those who want to use it can use the custom search URL option. That way, they can select a Searx instance that works for them.

#8

Updated by Soren Stoutner 5 months ago

  • Subject changed from Change the Searx instance to searx.neocities.org to Remove Searx from the list of search engines.
#9

Updated by Soren Stoutner 5 months ago

  • Status changed from In Progress to Closed
#10

Updated by Jesse M 5 months ago

I understand. They are only as good as the server hosting them I guess. I've thought about just hosting an instance locally, but I'm not fond of the idea of leaving a port open on my home desktop to the wide world so I could use it anywhere. Also I think I'd have to change the IP and port every time my VPN reconnects or use my home IP. A lot of trouble for a search engine. Maybe if I figure out a secure way to do it. SSH tunnel or something maybe.

Also available in: Atom PDF