Project

General

Profile

Feature #61

Backup settings / bookmarks with webdav

Added by TJ Spann about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
3.x
Start date:
09/09/2016
Due date:
% Done:

0%

Estimated time:

Description

The privacy features of this browser have made it the defacto standard for Android. My trouble is that unfortunately I use multiple devices and do not trust Google to steward my data from one device to the other. I have an owncloud server set up for that purpose but have yet to find a browser that supports webdav. This would be a great inclusion, were you to get the time to implement it.

History

#1

Updated by Soren Stoutner about 3 years ago

  • Assignee set to Soren Stoutner

TJ,

Thank you for the feature request. I am with you in that I do not trust any of my personal data to Google.

As you might be aware, there is an exisiting feature request to sync settings between devices:

https://redmine.stoutner.com/issues/23

The design of that feature is to export the settings to an encrypted file, probably using OpenKeychain to handle the encryption. The file will be placed at a location on the device selected by the user, and can then be synced by whatever program the user desires (ownCloud, Nextcloud, some proprietary service like Dropbox, etc.). Privacy Browser will have the option to to automatically export settings/bookmarks whenever there is a change and monitor the date on the file to automatically import changes made from other devices. There will also be an option to manually initiate an import/export. The encryption key will be manually entered in Privacy Browser on each device, so that the encrypted data is not available to the server that is syncing the file.

I have also considered teaching Privacy Browser to sync the files directly, using WebDav or some other protocol. I am not opposed to the idea of having multiple methods of syncing as long as each one provides an advantage not available to the others. Would the design of https://redmine.stoutner.com/issues/23 meet your needs?

#2

Updated by Soren Stoutner about 3 years ago

  • Status changed from New to Closed

As I have not received a response from TJ Spann, I am closing this feature request as a duplicate of https://redmine.stoutner.com/issues/23

In the future, if someone has a use case for direct webdav syncing, feel free to reopen the request.

Also available in: Atom PDF