Project

General

Profile

Actions

Bug #642

closed

View Source crashes on production builds

Added by Soren Stoutner almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Next Release
Start date:
11/19/2020
Due date:
% Done:

0%

Estimated time:

Description

This might fix a crash on Samsung devices. They crash consistently on opening View Source, which might be caused because of some bug in their modifications to Android that doesn't like the ViewModel being in Java and the ViewModelFactory being in Kotlin.

Actions #1

Updated by Soren Stoutner almost 2 years ago

I have been informed that at least one old Motorola phone also has problems with this.

Actions #2

Updated by Soren Stoutner almost 2 years ago

  • Subject changed from Convert the ViewWebSource ViewModel to Kotlin to View Source crashes on production builds

So, it turns out that this crashes on release builds on all devices. Most of my test devices run debug builds, which is why I wasn't able to replicate the issue.

Actions #3

Updated by Soren Stoutner almost 2 years ago

  • Tracker changed from Feature to Bug
  • Status changed from New to Closed

Fixed in commit https://git.stoutner.com/?p=PrivacyBrowser.git;a=commitdiff;h=606b5659cfd41c546fcbf248dcde72fd3c60d1c3.

The problem ended up being caused by ProGuard stripping out the ViewModel method during minification. This was fixed by adding a custom ProGuard rule.

Actions

Also available in: Atom PDF