Project

General

Profile

Bug #67

File downloading broken in API <= 22

Added by Soren Stoutner about 2 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Next Release
Start date:
10/22/2016
Due date:
% Done:

0%

Estimated time:

Description

Attempting to download a file causes a crase in API <= 22.

History

#1 Updated by Soren Stoutner about 2 years ago

  • Status changed from New to Closed

This was caused by calling `setDestinationInExternalFilesDir()`, which needs extra permissions in API <= 22. Fixed in commit https://git.stoutner.com/?p=PrivacyBrowser.git;a=commitdiff;h=1bd5ba3b9f91e69517fa8a39665256f0badc408b

#2 Updated by Soren Stoutner about 2 years ago

With this fix, downloads for API >= 23 are stored in the public /sdcard/Android/data/com.stoutner.privacybrowser.standard/files, while downloads for API <= 22 are stored in the private Download Manager internal storage.

#3 Updated by Soren Stoutner 10 months ago

  • Priority changed from 3 to Next Release

Also available in: Atom PDF