Project

General

Profile

Actions

Bug #699

closed

Crash after restarting in the settings activity and then toggling a switch

Added by Soren Stoutner over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Next Release
Start date:
04/30/2021
Due date:
% Done:

0%

Estimated time:

Description

The restart is handled correctly, but a subsequent toggling of a switch takes it down. Probably some problem with the handles for the preferences being stale.

Actions #1

Updated by Soren Stoutner over 1 year ago

  • Tracker changed from Feature to Bug
Actions #2

Updated by Soren Stoutner over 1 year ago

  • Priority changed from 3.x to Next Release

This is caused by calls to `getString()` in the `OnSharedPreferencesChangeListener`, which fails with no context if the app has been restarted.

Actions

Also available in: Atom PDF