Project

General

Profile

Actions

Feature #8

closed

Scroll the AppBar

Added by Soren Stoutner over 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Next Release
Start date:
03/02/2016
Due date:
% Done:

0%

Estimated time:

Description

The desire is to scroll the AppBar with the WebView content. This bug is currently blocked by https://code.google.com/p/android/issues/detail?id=200394. Also see discussion at https://code.google.com/p/android/issues/detail?id=198965.

Actions #1

Updated by Soren Stoutner over 6 years ago

  • Description updated (diff)
Actions #2

Updated by Soren Stoutner over 6 years ago

  • Assignee set to Soren Stoutner
Actions #3

Updated by Soren Stoutner over 5 years ago

  • Priority changed from 3.x to 3
Actions #4

Updated by Soren Stoutner about 5 years ago

  • Priority changed from 3 to 2
Actions #5

Updated by Soren Stoutner almost 4 years ago

  • Priority changed from 2 to Next Release

It will be important to implement this before tabbed browsing or too much screen real estate will be lost on smaller devices.

Actions #7

Updated by Soren Stoutner over 3 years ago

Overriding `onTouchEvent()` might require calling `performClick()` and implementing custom code there.

https://developer.android.com/reference/android/view/View#onTouchEvent(android.view.MotionEvent)

Actions #9

Updated by Soren Stoutner over 3 years ago

  • Status changed from New to Closed
Actions #10

Updated by my self over 3 years ago

I want to report an issue possibly caused by the introduction of this feature. Some pages (for example https://mobile.twitter.com/Twitter) are now cutted at the bottom and scrolling incorrectly in release >= 2.17 when the "scroll app bar" feature is disabled in settings. Thank you.

Actions #11

Updated by Soren Stoutner over 3 years ago

When the implementation of a new feature creates a bug, it is best to open a new bug report instead of commenting in the existing feature request. It makes the tracking easier. I have created https://redmine.stoutner.com/issues/398 for this purpose.

Actions

Also available in: Atom PDF