Project

General

Profile

Actions

Feature #838

closed

Add a Share Message option

Added by Il Av 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Next Release
Start date:
03/29/2022
Due date:
% Done:

0%

Estimated time:

Description

Hello,

I'm using a nextcloud server. There is an app called "nextcloud bookmarks" you can share some links with the app an the app will store the links in the nextcloud.

To use the app you have to share the link with the app. The app will automatically fill a popup and you just have to save the link. When I share the link with the privacy browser the app is not filled correctly. I will attend 3 pictures to show my problem. When I share the link with an other browser all is filled correctly.

I hope you understand what I mean.


Files

Actions #1

Updated by Soren Stoutner 4 months ago

  • Subject changed from Nextcloud Bookmarks support to Add a second share URL entry that works with Nextcloud bookmarks

Privacy Browser's share URL option was designed to share the URL with a messaging app. As such, it produces all the output in one field, with the page title first, then a dash, and then the URL.

It would be possible to create a separate share option that only lists the URL in the main payload and includes the title in a different field.

Can you check to see if it works correctly with Lightning?

https://f-droid.org/en/packages/acr.browser.lightning/

If so, then the data field that Nextcloud is using for the title is EXTRA_SUBJECT.

https://developer.android.com/reference/android/content/Intent#EXTRA_SUBJECT

The other question is what should the new entry be called so that users understand the difference between it and the current `Share URL` entry?

Actions #2

Updated by Il Av 4 months ago

Hi,

with lightning everything works fine. So we know what we need.

It's not really sharing a link so it could be placed in "open with app" but there are just browsers to choose.

Maybe it's possible to make a "save bookmark" option in combination with the bookmark on the right display menu.

So when you choose "save bookmark" you can choose if you want to open this in an other app (nextcloud bookmarks app) or privacy browser itself. When opening in the privacy browser it greater an bookmark in privacy browser (right side swipe option).

Actions #3

Updated by Il Av 4 months ago

Hi,

with lightning everything works fine. So we know what we need.

It's not really sharing a link so it could be placed in "open with app" but there are just browsers to choose.

Maybe it's possible to make a "save bookmark" option in combination with the bookmark on the right display menu.

So when you choose "save bookmark" you can choose if you want to open this in an other app (nextcloud bookmarks app) or privacy browser itself. When opening in the privacy browser it greater an bookmark in privacy browser (right side swipe option).

Actions #4

Updated by Soren Stoutner 4 months ago

I am going to have to ponder a bit more over the name. In the case of Nextcloud bookmarks `Save Bookmark` would work, but this entry could also be used for other purposes by other users. For example, a little bit of testing shows that when shared with an email program it populates the subject with the title and the body with the URL.

Perhaps it would make sense to rename the existing entry to `Share Message` and call the new entry `Share URL`. This makes a bit of sense to me because, for apps that are only looking for one piece of information like a text message app, this new entry only populates the URL.

Updated by Soren Stoutner 4 months ago

There are two possibilities for the share menu. One involves creating a chooser (see screenshot), which provides options like seeing the text on the screen and having a list of recent contacts. It does not allow the selection of a default that will always be used in the future. This is the method currently used by Share URL because I like the layout and the options better, and I thought it would be unlikely that someone would usually want to only share to one source, so the option to have a default wouldn't be helpful for most people.

The second option shares without creating an explicit chooser (see screenshot). This screen presents the programs in a list instead of a grid, it doesn't show individual contacts inside an app, it doesn't show the text that is being shared, but it does allow the selection of a default. If the default is selected, this screen is not shown again (unless the user resets the defaults in the receiving app in the Android OS app settings). Users do not need to select a default if they do not want to. But I can imagine that, in many cases, and individual user might only ever want to use this new share menu with a specific app.

Which do you think the majority of users would prefer?

Actions #6

Updated by Il Av 4 months ago

I definitely would prefer the version with chooser. Like you sad there are more options and you'll see the shared text.

These will be the renamed open "share message"?

And the "share URL" option will be used for e.g. Nextcloud bookmarks or other apps that separate the header and URL?

Maybe some user will be confused when the "share URL" is now another feature and have to use "share message" instead.

Actions #7

Updated by Soren Stoutner 4 months ago

It is true that it might be confusing at first, but I don't think it will end up being that bad. First of all, I would put the new Share Message entry in the first spot where Share URL used to be (see attached screenshot). A lot of users will just continue to hit the first entry without even noticing it has changed. Also, people can see the text at the top of the chooser menu, so it should be fairly obvious to them what they will get after they try each one once. Beyond that, there is also the blog post in the standard location which will describe the changes in depth for anyone who is curious.

https://www.stoutner.com/category/privacy-browser-android/

Actions #8

Updated by Il Av 4 months ago

The new share menu looks fine and like you said, the most people will even click the first point and still woun't notice that somthing was chanched.

In the end everything will be fine ;)

I hope it wasn't too much work to chanche the feature reques and your timeline isn't disturbed.

This is the reason I like open souce so much. All people are still nice and you can contact the developer and still care about you.

Thank you very much! :-)

Actions #9

Updated by Soren Stoutner 4 months ago

  • Status changed from New to Closed
Actions #10

Updated by Soren Stoutner 4 months ago

  • Subject changed from Add a second share URL entry that works with Nextcloud bookmarks to Add a Share Message option
Actions

Also available in: Atom PDF