Project

General

Profile

Actions

Bug #952

closed

Tabs misbehave if the app theme is different from the OS theme

Added by Bobby Hiltz about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Critical Bug
Start date:
01/04/2023
Due date:
% Done:

0%

Estimated time:

Description

Running the latest version available from the website.

When trying to open a bookmark, it will not load in the active tab. If I click on + for a new tab, the bookmark will be opened there, which the tab title "New tab".

Things I have tried:

  • Clear and Exit
  • Clear cache and storage
  • Installing from F-Droid and from the site

Files

screen-20230104-135829.mp4 (6.15 MB) screen-20230104-135829.mp4 Bobby Hiltz, 01/04/2023 06:03 AM
versioninfo.txt (1.22 KB) versioninfo.txt Bobby Hiltz, 01/04/2023 06:08 AM
Actions #1

Updated by Soren Stoutner about 1 month ago

  • Status changed from New to Feedback
  • Assignee set to Soren Stoutner
  • Priority changed from 3.x to Next Release

Are you perchance using a dark app theme and a light OS theme?

If so, can you try seeing if making them match resolves the issue, either by using a light OS theme and a light app theme or a dark OS theme and a dark app theme?

Actions #2

Updated by Bobby Hiltz about 1 month ago

It turns out that I was. Not intentionally, though. That does seem to have resolved the issue. I set everything to follow the system and now it works as it did before.

Thanks for the quick response.

Actions #3

Updated by Soren Stoutner about 1 month ago

  • Status changed from Feedback to In Progress
  • Priority changed from Next Release to Critical Bug

This appears to be a recurrence of an old bug #605. Basically, the app always starts with the same theme as the OS. If the app specifies the opposite theme then it restarts quickly in the other mode. However, in the past I had to delay the initialization of certain parts of the app or else it would restart while they were initializing which resulted in unexpected behavior (like the app not knowing how many tabs it has open).

With the past release a number of the features involved with initializing the app were migrated from Java to Kotlin, which appears to have a speed benefit, but also seems to have triggered this buggy behavior again.

Actions #4

Updated by Soren Stoutner about 1 month ago

  • Subject changed from Bookmarks not opening in active tab to Tab misbehaving if the app theme and the OS theme are different
Actions #5

Updated by Soren Stoutner about 1 month ago

  • Subject changed from Tab misbehaving if the app theme and the OS theme are different to Tabs misbehave if the app theme is different from the OS theme
  • Status changed from In Progress to Feedback

I have created a test build that fixes this problem on my device, but because sometimes this type of race condition manifests differently on different devices, I would like to see if you can test it on your device. The test build can install next to your existing copy of Privacy Browser (the icon will have the word TEST on it). You can export and import your settings from your current version of Privacy Browser to the test build. If everything works well for you with the test build when the app theme is set to be different from the OS them then I will prepare it for a general release.

The test build can be downloaded at the following URL (the link will expire after a few days):

https://nextcloud.stoutner.com/s/MQfBHxnedDnjB47

Actions #6

Updated by Bobby Hiltz about 1 month ago

I've installed the Test Build and am using it now. Seems to work despite theme changes, but I'll use it for a full day at least.

Actions #7

Updated by Bobby Hiltz about 1 month ago

Spent the day trying to recreate the bug on the test build. Couldn't do it. I changed themes on my phone and in the browser, mixed and matched. It works as it should.

However, now whenever I need to login anywhere, Bitwarden proposes 4 items that are not the site I am trying to connect to.

Example:

Trying to connect to GitHub, it proposes stoutner.com, alternativeto.net and a flower delivery site. I don't know if that is related to the browser or to Bitwarden though.

Actions #8

Updated by Soren Stoutner about 1 month ago

Try downloading the Alt (test) version of Privacy Browser 3.13 or 3.13.2 and see if Bitwarden does the same thing with them.

https://www.stoutner.com/privacy-browser-android/changelog/

You will need to uninstall the current test version of Privacy Browser to install an older one.

Actions #9

Updated by Bobby Hiltz about 1 month ago

3.13 Test version: Bitwarden does the same thing, proposes the same sites.

Actions #10

Updated by Soren Stoutner about 1 month ago

I would assume that means that something has changed on Bitwarden's end, as it appears you didn't have these symptoms previously with 3.13.

I am going to go ahead and close this bug and prepare a release. If you discover that the Bitwarden problem does relate to something in Privacy Browser's code, feel free to open a new bug report about the issue.

Actions

Also available in: Atom PDF