Project

General

Profile

Bug #131

Text in drop-down list needs more space

Added by Thomas Jensen over 1 year ago. Updated 10 months ago.

Status:
Closed
Priority:
Next Release
Start date:
05/19/2017
Due date:
% Done:

0%

Estimated time:

Description

The drop-down list in Domain Settings -> User Agent looks wierd - see screenshot.

My phone use normal text size, and I have never had problems with text looking like this.

Screenshot_20170519-145142.png (141 KB) Screenshot_20170519-145142.png Thomas Jensen, 05/19/2017 07:34 AM

History

#1 Updated by Soren Stoutner over 1 year ago

  • Assignee set to Soren Stoutner
  • Priority changed from 3.x to 2.x

Thomas,

Thanks for the bug report. I am bumping the priority up to Normal as I think this issue is too annoying to be considered Low.

Please send me a screenshot of About → Version. My guess is this is some sort of incompatibility between the spinner menu and the verison of Android you are running that probably only manifests when the spinner menu is large enough that it should require scrolling. In your case it looks like instead of scrolling it is trying to scrunch it all onto the screen by cutting off the font. My hope is there is some sort of AppCompat workaround I can use to fix the issue.

Also, can you confirm if the font size spinner menu looks correct? It is the next item below the user agent. The only difference is that it shouldn't be large enough to require scrolling.

#2 Updated by Soren Stoutner over 1 year ago

  • Priority changed from 2.x to 3.x

Based on the screenshot you sent me it looks like you have a Huawei P9 Lite running Android 7.0 (API 24). I am not able to replicate this problem on any of my physical devices, nor in an emulator running Android 7.0.

Looking online I noticed that this device just got an upgrade in the past month or so from Android 6.x to 7.0. Also, by looking at the status icons, it seems like Huawei has done a fair amount of tweaking to the Android OS. My guess is that they have inadvertantly done something to break the layout of spinner menus that are large enough to require scrolling. If so, it is possible that they will fix the issue in an upcoming update.

If my analysis of the problem is correct, there isn't much I can do to fix the problem except to make the list shorter (but I don't really want to remove any of the items from the list) or make the font smaller on the list (which might cause problems for those with poor eyesight). You could also see what happens if you set the system font to be tiny, but that might create an unacceptable experience with other parts of the phone.

For now, I am going to lower the priority to Low but leave this bug report open. I'm curious to see if this is something Huawei fixes in the next few months.

#3 Updated by Soren Stoutner over 1 year ago

There is an outside chance that the problem can be fixed by using an `AppCompatSpinner` instead of a `Spinner`. Please try testing one of these debug builds and let me know if it makes a difference.

Privacy Browser debug build. Installing this will require uninstalling the current version of Privacy Browser on your phone. Unless you have root and can backup the data, you will lose all your bookmarks and settings.
https://download.stoutner.com/privacy-browser/app-standard-debug.apk

Privacy Browser Free debug build. You can install this alongside your current Privacy Browser installation. It contains a banner ad across the bottom of the screen, but otherwise functions exactly the same.
https://download.stoutner.com/privacy-browser/app-free-debug.apk

#4 Updated by Soren Stoutner over 1 year ago

  • Status changed from New to In Progress

Based on user feedback, using `AppCompatSpinner` didn't make any difference. At this point, I'm inclined to wait a few months and see if a Huawei update fixes the issue.

#5 Updated by Soren Stoutner over 1 year ago

  • Priority changed from 3.x to 3

I am setting the priority to high, as this is a problem I would like to fix as soon as possible, but I realize there probably isn't anything I can do until Huawei fixes their problem.

#6 Updated by Soren Stoutner over 1 year ago

  • Status changed from In Progress to Closed

The solution is to hard code the layout for the `DropDownViewResourece`. It appears that Huawei has done something untoward with these settings in their customization.

Thanks to Thomas for discovering the fix.

Fixed in commit https://git.stoutner.com/?p=PrivacyBrowser.git;a=commitdiff;h=768db69b4dceb8ab01e18ef1ab0e692c9ed1257b.

#7 Updated by Soren Stoutner over 1 year ago

The problem resurfaced, along with a font size problem on other devices. I reworked all the settings to be explicit instead of relying on the default Android layouts, which hopefully fixes the problem on all devices.

https://git.stoutner.com/?p=PrivacyBrowser.git;a=commitdiff;h=27f29c3b890c9ec20620961c6e77805630dd339f

#8 Updated by Soren Stoutner 10 months ago

  • Priority changed from 3 to Next Release

Also available in: Atom PDF