Project

General

Profile

Feature #395

A bookmark makes the app crash

Added by JB Hétier 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Critical Bug
Start date:
03/03/2019
Due date:
% Done:

0%

Estimated time:

Description

Bookmarking this page makes the app crash:
http://www.lesrecettesdevirginie.com/2014/07/cotes-de-bettes-en-gratin.html

Any subsequent access to the directory in which I put the bookmark makes the app crash.

I enclose a logcat (thanks to the newly added feature :))


Files

bookmark-logcat.txt (4.66 KB) bookmark-logcat.txt Logcat of the crash JB Hétier, 03/03/2019 07:09 AM

History

#1

Updated by Soren Stoutner 3 months ago

  • Assignee set to Soren Stoutner
  • Priority changed from 3.x to Critical Bug
#2

Updated by Soren Stoutner 3 months ago

The problem is caused because the favicon for this site is a 188 KB JPEG, which is converted into a 1.9 MB PNG when entering the database. It can go into the database, but it can't fit in the cursor coming out of the database (which has a 2 MB limit by default).

http://img.over-blog-kiwi.com/1/02/97/00/20150325/ob_424e88_3043265.JPG

The 2MB cursor window size can be increased beginning in API 28. https://developer.android.com/reference/android/database/CursorWindow.html#CursorWindow(java.lang.String,%20long)

#3

Updated by Soren Stoutner 3 months ago

  • Status changed from New to Closed

Fixed in commit https://git.stoutner.com/?p=PrivacyBrowser.git;a=commitdiff;h=55169899d6454cd57e40d32a792735df51caee85, which will be included in the upcoming 2.17.1 release.

#4

Updated by Soren Stoutner 3 months ago

Note that this release will scale down favorite icons for new bookmarks, but it will not fix existing bookmarks with images that are too large. If you have a recent backup you can go back to that. Or you can delete the folder with the bad bookmark and recreate it. JB, if that would cause too many problems for you, please email me directly at and I can look at doing something custom for you to delete just this problematic bookmark without causing your other settings to be lost.

Also available in: Atom PDF