Project

General

Profile

Bug #464

Rare crash while loading an intent

Added by Soren Stoutner 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Next Release
Start date:
06/10/2019
Due date:
% Done:

0%

Estimated time:

Description

This crash happens every once in a while while loading an intent while Privacy Browser is resuming.

FATAL EXCEPTION: main
Process: com.stoutner.privacybrowser.standard, PID: 24366
java.lang.IndexOutOfBoundsException: Index: -1, Size: 1
at java.util.LinkedList.checkElementIndex(LinkedList.java:555)
at java.util.LinkedList.get(LinkedList.java:476)
at com.stoutner.privacybrowser.adapters.WebViewPagerAdapter.getPageFragment(WebViewPagerAdapter.java:121)
at com.stoutner.privacybrowser.dialogs.SslCertificateErrorDialog.onCreateDialog(SslCertificateErrorDialog.java:126)
at androidx.fragment.app.DialogFragment.onGetLayoutInflater(DialogFragment.java:330)
at androidx.fragment.app.Fragment.performGetLayoutInflater(Fragment.java:1308)
at androidx.fragment.app.FragmentManagerImpl.moveToState(FragmentManager.java:1460)
at androidx.fragment.app.FragmentManagerImpl.moveFragmentToExpectedState(FragmentManager.java:1784)
at androidx.fragment.app.FragmentManagerImpl.moveToState(FragmentManager.java:1852)
at androidx.fragment.app.BackStackRecord.executeOps(BackStackRecord.java:802)
at androidx.fragment.app.FragmentManagerImpl.executeOps(FragmentManager.java:2625)
at androidx.fragment.app.FragmentManagerImpl.executeOpsTogether(FragmentManager.java:2411)
at androidx.fragment.app.FragmentManagerImpl.removeRedundantOperationsAndExecute(FragmentManager.java:2366)
at androidx.fragment.app.FragmentManagerImpl.execPendingActions(FragmentManager.java:2273)
at androidx.fragment.app.FragmentManagerImpl$1.run(FragmentManager.java:733)
at android.os.Handler.handleCallback(Handler.java:873)
at android.os.Handler.dispatchMessage(Handler.java:99)
at android.os.Looper.loop(Looper.java:193)
at android.app.ActivityThread.main(ActivityThread.java:6718)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:493)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:858)

The problem is that the SSL certificate error dialog cannot find the NestedScrollWebView it is looking for.

History

#1

Updated by Soren Stoutner 2 months ago

This is likely some sort of race condition with the loading of the WebView fragments list while resuming Privacy Browser.

#3

Updated by Soren Stoutner 2 months ago

  • Status changed from New to Closed

Also available in: Atom PDF