Project

General

Profile

Actions

Bug #595

closed

Closing a tab does not clear the audio buffer

Added by Soren Stoutner about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Next Release
Start date:
08/03/2020
Due date:
% Done:

0%

Estimated time:

Description

This can sometimes be demonstrated by closing a tab playing a YouTube video.

Actions #1

Updated by Soren Stoutner about 2 years ago

  • Tracker changed from Feature to Bug
Actions #2

Updated by Soren Stoutner about 2 years ago

  • Priority changed from 3.x to Next Release
Actions #3

Updated by Soren Stoutner about 2 years ago

This will time out after a while, so you can't listen to music forever this way. In my testing, I have not seen this play for longer than 5 minutes.

Actions #4

Updated by Soren Stoutner almost 2 years ago

In my testing in the past, this has been because the audio is buffered by an OS component. Even when the WebView was destroyed, that buffered data was retained, and would play out. However, none of my testing on my current devices now behave that way, which makes me think it was fixed by an update to WebView.

Just to be sure, I am going to manually pause the WebView and the JavaScript timers before deleting a tab.

Actions #6

Updated by Soren Stoutner almost 2 years ago

After fixing this bug, I experienced similar behavior once, which is described at https://redmine.stoutner.com/issues/638. If anyone can reliably reproduce this, it would be very helpful in figuring out what is going on.

Actions

Also available in: Atom PDF