Project

General

Profile

Actions

Feature #844

closed

url redirecting

Added by xphnx the-flow almost 2 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
3.x
Start date:
04/19/2022
Due date:
% Done:

0%

Estimated time:

Description

Any chance to implement URL redirecting as https://www.f-droid.org/en/packages/app.fedilab.nitterizeme/ do?

Twitter -> Nitter
Youtube -> Invidious
Instagram -> Bibliogram
Reddit -> Teddit
Wikipedia -> Wikiless

Thanks for your work, really amazing!


Files

Domain Redirection (1).png (240 KB) Domain Redirection (1).png ask low, 03/12/2024 02:58 PM
Actions #1

Updated by Soren Stoutner almost 2 years ago

  • Status changed from New to Closed

This is a duplicate of https://redmine.stoutner.com/issues/502. You can leave any comments you have there.

Actions #2

Updated by ask low about 1 month ago

That wouldn't accomplish all this feature request needs to do. I think it is best to leave URL modification as a separate interface.

I think it would at least accomplish this FR though.

Actions #3

Updated by Soren Stoutner about 1 month ago

I am not inclined to spend time on a partial implementation of this feature just to have to rip it out to do a full implementation.

Actions #4

Updated by ask low about 1 month ago

I'm interested to know how this kind of implementation would be partial btw ?

Actions #5

Updated by Soren Stoutner about 1 month ago

Because it would only edit the domain and not other aspects of the URL. The full implementation needs to be able to modify any part of the URL, which is not something that can be done inside of domain settings without causing problems. It needs to be a separate feature that runs before domain settings.

Actions #6

Updated by ask low about 1 month ago

If you mean #502, that FR asks for complete URL modification (which I don't think it's even worth implementing).
But Domain Redirection is a subset of URL modification. This FR achieves just the needed function. To redirect to another domain by keeping the root same.

Actions #7

Updated by Soren Stoutner about 1 month ago

I appreciate your feedback, but I don't think implementing partial URL modification is worth the effort, because the goal is to implement full URL modification (which is useful to a lot of people). Therefore, this feature request is closed, because it will be handled by Feature #502: Create a user configurble URL modification.

Actions

Also available in: Atom PDF